Back to overview
Resolved

US-East-1a Down

Aug 1, 2026 at 1:30am UTC
Affected services
Game Servers - US East

Resolved
Aug 1, 2026 at 2:35am UTC

The server is back on-line. All game servers are available.

Updated
Aug 1, 2026 at 1:50am UTC

Your worlds and saves are safe. They're stored separately from the affected hardware and we've verified them. Nothing is lost, and servers will come back with their factories intact once the hardware is restored. We're continuing to work with on-site technicians.

Updated
Aug 1, 2026 at 1:48am UTC

We are working with the on-site technicians to diagnose and remediate the hardware issue.

Created
Aug 1, 2026 at 1:30am UTC

Server hardware has failed and is currently offline. We are working with our provider for a resolution.